// //

Thursday, October 27, 2016 - Welcome, guest user!

Garmin Firmware v3.40 issues…

Saturday, January 10, 2015 by  
Filed under Daily Blog


A few days ago Garmin Express auto-updated my Edge 810 from firmware v3.20 to v3.40.

After the update the initial setup dialog box was presented, and I was afraid all my settings had been lost. Thankfully once I ran through the 5 or 6 quick initial setup questions, all my ride profiles, bike profiles and other settings were still there.

Unfortunately my Edge 810 starting experiencing quite a few problems after the firmware upgrade…

The very first sign of trouble came right after the update when I did a short test while sitting at my desk. When I told the Edge to discard the ride, it locked up.

Also after the upgrade my Edge no longer had a Bluetooth connection to my phone, and it took several paring attempts/reboots of the Edge before the connection was finally established.

The next day I did my first ride, and there were all kinds of problems.

Garmin Edge 810 mounted on my Madone's K-edge Garmin mount.

Garmin Edge 810 mounted on my Madone’s K-edge Garmin mount.

I have a screen with all my ride averages (speed, cadence, power, etc) and another screen with my total vertical ascent and other elevation-related data. The fields were all there, but none of them were populated with data. I stopped my ride, deleted and then re-added the fields, but that didn’t fix it. Finally, I rebooted the Edge and that did the trick.

On that same ride I noticed several cadence dropouts (speed/cadence sensor battery was just replaced on January 1st).

About 2 miles into my ride the Edge lost its connection with my phone, ending my Live Track session. This has never happened on any previous firmware.

Finally, my displayed heart rate was way off: erratic and often much higher than it really was.

When I returned home I removed and then re-paired all my devices (phone, HR strap, power meter and speed/cadence sensor). I did another test at my desk, and everything seemed okay.

The next day I went for a ride, and still experienced all the same issues as the day prior.

Before rolling back to v3.20, I decided to try a master reset (after backing up my settings and data, of course). I’ve only done one ride since then, but I experienced almost none (more on the remaining problem below) of the aforementioned issues on that ride. My phone remained connected the entire time, Live Track worked and all my data was displayed without issue. That was a short 20 mile ride, though. I’m doing a long ride today, so this will be a much better test.

The one problem that is still present is my displayed heart rate. I replaced the battery in my heart rate strap, but on yesterday’s ride there was definitely still something wrong. I did a very light recovery ride, and my average heart rate was 149 BPM. Normally my heart rate would have been in the low 100s on a ride like that. There were sections of the ride where I was soft-pedaling at about 100 watts, and my HR was at 160 BPM! At one point on the ride I dropped the hammer and my average HR was 151 BPM on that section (I could tell it was actually in the upper 180s, if not higher). Definitely something still wrong there.

I’ve still got my old Edge 500 here and a backup HR strap, and so this weekend I’m going to experiment with various combinations of the two Edge computers and two HR straps. A good test will be to pair my main strap to both devices, and see if there is a difference between the displayed heart rates (obviously there should not be).

Some of my friends with Edge 810s and 510s have reported various problems with FW v3.40. Feel free to chime in if you are (or are not) having issues.

John Stone Fitness Comments

One Response to “Garmin Firmware v3.40 issues…”
  1. My friend and I both ride with the 510. He’s had similar issues where cadence, heart rate, and speed were consistently failing to report or showing inaccurate numbers. My cadence dropped once but it could have been a fluke. He took his back to the store where he purchased it and I believe they are sending his unit back to Garmin.

    GD Star Rating

Speak Your Mind

Tell us what you're thinking...

You must be logged in to post a comment. Not yet a member? Registration is fast and free!